Funnel Form Domain Outage

Incident Report for Digistorm

Resolved

This incident is now resolved. Thank you for your patience.
Posted Mar 27, 2025 - 14:55 AEST

Identified

We've identified an issue with Funnel form domains affecting a small group of schools and we are currently investigating.
Posted Mar 26, 2025 - 09:44 AEST
This incident affected: Funnel (Forms).