Funnel - Emails

Incident Report for Digistorm

Resolved

This incident has been resolved. Thank you so much for your patience.
Posted May 01, 2026 - 14:01 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2026 - 10:59 AEST

Identified

We’ve identified the issue impacting Funnel emails for schools and are working on resolving it.
Posted May 01, 2026 - 10:01 AEST

Investigating

We’ve identified an issue impacting Funnel emails for schools and are actively investigating to resolve it.
Posted May 01, 2026 - 09:47 AEST
This incident affected: Funnel (Email).