Funnel Outage

Incident Report for Digistorm

Resolved

Funnel is back online. We have resolved the issue that was causing Funnel to be unavailable or return an error. We apologise for any inconvenience caused.
Posted Jul 02, 2026 - 17:57 AEST

Investigating

We are currently investigating reports that Funnel is unavailable or returning an error.
Posted Jul 02, 2026 - 16:40 AEST
This incident affected: Funnel (CRM, Forms, Email, Events, Bookings, Automations, Payments, API).