Scheduled Maintenance: Funnel
Incident Report for Digistorm
Resolved
Scheduled maintenance on Funnel has now been completed.

Thank you for your patience and understanding!
Posted Dec 19, 2022 - 10:40 AEST
Update
We'll let you know once scheduled maintenance has been completed. Thank you again for your patience and understanding!
Posted Dec 19, 2022 - 08:36 AEST
Identified
We’re currently performing scheduled maintenance on Funnel. You won’t be able to access your Funnel from approximately 08:30 - 11:30 AEST. You'll be able to access your Funnel account once maintenance is completed. Thank you for your patience and understanding!
Posted Dec 19, 2022 - 08:35 AEST
This incident affected: Funnel (CRM, Forms).