Funnel - Outage

Incident Report for Digistorm

Resolved

This incident is now resolved. Thank you for your patience.
Posted Jun 19, 2025 - 16:42 AEST

Investigating

We are currently investigating reports that Funnel is unavailable or returning an error.
Posted Jun 19, 2025 - 14:47 AEST
This incident affected: Funnel (CRM, Forms, Email, Events, Bookings, Automations, Payments, API).