Degraded Performance on emails sent from Funnel & Enrol
Incident Report for Digistorm
Resolved
This incident has been resolved. All communications should restore back to normal.
Posted Aug 07, 2020 - 13:11 AEST
Update
We are continuing to monitor for any further issues.
Posted Aug 07, 2020 - 13:10 AEST
Update
We are continuing to monitor for any further issues.
Posted Aug 07, 2020 - 10:30 AEST
Monitoring
Our email provider has identified and fixed the issue. Digistorm will continue to monitor the platform for stability and deliverability.
Posted Aug 07, 2020 - 10:27 AEST
Identified
Digistorm wishes to advise that our email provider has identified an issue with outbound emails. This is currently impacting our communications for Funnel and Enrol.

This issue is currently being investigated and we will continue to monitor and pass on any updates as they become available. If you have any questions or concerns, please reach out to support@digistorm.com
Posted Aug 07, 2020 - 09:42 AEST
This incident affected: Enrol, Forms, and Funnel.