Digistorm Funnel - Degraded performance

Incident Report for Digistorm

Resolved

Funnel is fully operational and the identified issue is resolved.
Posted Oct 16, 2025 - 16:35 AEST

Monitoring

Our team has investigated and resolved the issue, and Funnel is being monitored for stability. We thank you for your patience and continued support.
Posted Oct 16, 2025 - 15:12 AEST

Investigating

We’re currently experiencing degraded performance issues with Funnel. Rest assured, our team is working hard behind the scenes to restore normal performance levels.
Posted Oct 16, 2025 - 14:54 AEST
This incident affected: Funnel (CRM, Forms, Email, Events, Bookings, Automations, Payments, API).