Intermittent performance issues on Funnel
Incident Report for Digistorm
Resolved
The intermittent performance issues have now been resolved. Thank you for your patience.
Posted Oct 18, 2023 - 19:02 AEST
Investigating
We're aware of intermittent performance issues on Funnel. Thank you for your patience as our team investigates the issue as a priority.
Posted Oct 18, 2023 - 15:49 AEST
This incident affected: Funnel (CRM).