Funnel users experiencing technical issues
Incident Report for Digistorm
Resolved
Thank you for your understanding while our team monitored yesterday's fix roll out.
Posted Oct 12, 2021 - 13:30 AEST
Monitoring
We are aware some Funnel users were facing intermittent issues when attempting to access Funnel earlier. A fix has been rolled out and our team is currently monitoring the situation. Thank you for your understanding and patience.
Posted Oct 11, 2021 - 15:36 AEST
This incident affected: Funnel (CRM).