Funnel Degraded Performance

Incident Report for Digistorm

Resolved

This incident has been resolved. There was an issue with our queue workers which prevented queued jobs from being processed. All delayed jobs have been re-run and Funnel is fully operational.
Posted Jul 15, 2026 - 14:13 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2026 - 13:49 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 15, 2026 - 13:17 AEST

Investigating

We’re currently experiencing degraded performance issues with Funnel. Rest assured, our team is working hard behind the scenes to restore normal performance levels.
Posted Jul 15, 2026 - 12:29 AEST
This incident affected: Funnel (CRM, Forms, Email, Events, Bookings, Automations, Payments, API).