Funnel - Outage

Incident Report for Digistorm

Resolved

This incident has been resolved. Thank you for your patience.
Posted Mar 24, 2025 - 19:14 AEST

Monitoring

A fix has been implemented and we are monitoring.
Posted Mar 24, 2025 - 15:35 AEST

Identified

We have identified the cause of the Funnel outage and our engineers our working to get Funnel back online as soon as possible. We will provide an update as soon as we have restored network functionality.
Posted Mar 24, 2025 - 13:51 AEST
This incident affected: Funnel (CRM, Forms, Email, Events, Bookings, Automations, Payments, API).