Funnel Form Payments

Incident Report for Digistorm

Resolved

This incident has been resolved.
Posted Nov 13, 2024 - 14:04 AEST

Monitoring

Between 10:21 AM November 13 and 12:07 PM November 13 (AEST) there was an issue with payments not processing. We're monitoring the issue and it appears to be resolved. We appreciate your patience while we worked on this and apologise for any inconvenience this may have caused. Thank you for your understanding.
Posted Nov 13, 2024 - 12:07 AEST

Identified

We have identified the issue and the issue will be fixed shortly.
Posted Nov 13, 2024 - 11:45 AEST

Investigating

We are currently investigating failed payments on forms that may be affecting a number of schools.
Posted Nov 13, 2024 - 11:43 AEST
This incident affected: Funnel (Payments).