Website Email Outage

Incident Report for Digistorm

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 14:19 AEST

Monitoring

A fix has been implemented and we are currently monitoring to confirm no further issues.
Posted Jun 17, 2026 - 17:04 AEST

Investigating

We're currently experiencing an issue where all website emails are failing to send. Our team is actively investigating and will provide an update shortly.
Posted Jun 17, 2026 - 11:30 AEST
This incident affected: Website (AU Region, EU Region, US Region, SG Region).